Loading
Loading

:: Izak.pt ::

Also known as Mozack!

[PRESTASHOP] Erro HTTPS na versão 1.5.5.0

Olá,

Desde o meu último post sobre o módulo blocklayered, fiz a atualização do PrestaShop da versão 1.5.4 para 1.5.5.0. Nesta atualização deparei-me com um erro em https ao carregar o controller cart. A página estava em HTTPS mas o conteúdo do blockcart (ajax) era carregado em http, o que na realidade, dava uma mensagem de erro que dizia que tenha conteúdo não seguro.

Vi ficheiro por ficheiro e passadas algumas horas lá encontrei o erro que fazia com que esse url (/?controller=cart&ajax=true) fosse carregado por http em vez de https.

Para os utilizadores que sofrem do mesmo problema, aqui fica o fix:

Abram o ficheiro /classes/controller/FrontController.php e por volta da linha 110 encontram:


Substituam este código por:

Problema resolvido… Espero que resolva o vosso também.

Abraços

Mozack

Leave a comment

Please be polite. We appreciate that.

By Daniele Zedda • 18 February

← PREV POST

By Daniele Zedda • 18 February

NEXT POST → 34
Share on
2007 - 2017 © izak.pt Todos os direitos reservados.